Recently I came across this error a few times on DirectAdmin installations. I first noticed this error when I installed Nextgen Gallery plugin on some WordPress installation. When I tried to upload some pictures, php should resize them and create thumbnails, but instead of thumbnails I’ll get error about JPEG library (checked in error log). Below is procedure on how to fix that error. At least it worked for me. This Directaadmin was installed on FreeBSD 9.1.

 

  1. Login as root
  2. Update ports

    [root@lala ~]# portsnap fetch update

  3. Delete currently installed JPEG library

    [root@lala ~]# pkg_info | grep jpeg
    [root@lala ~]# pkg_delete <yourjpegversion>

  4. Install jpeg library with ports

    [root@lala ~]# whereis jpeg
    jpeg: /usr/ports/graphics/jpeg
    [root@lala ~]# cd /usr/ports/graphics/jpeg
    [root@lala /usr/ports/graphics/jpeg]# make install clean

  5. Edit your configuration script for php in custombuild. Add or edit values as bellow. Notice that path is not /usr/local/lib anymore.

    –with-gd \
    –with-jpeg-dir=/usr/local \

  6. Rebuild PHP with custombuild

    [root@lala ~]# cd /usr/local/directadmin/custombuild
    [root@lala /usr/local/directadmin/custombuild]# ./build php n

  7. When build is complete, restart Apache and try it again. It should work.

    [root@lala ~]# /usr/local/etc/rc.d/httpd restart

Dodaj odgovor

Vaš e-naslov ne bo objavljen. * označuje zahtevana polja